Per 31 december 2018 heeft PHP 5.6 officieel zijn EOL, of "End of Life", datum bereikt. Dit betekent dat PHP geen verdere support of veiligheidsupdates meer voor deze versie uitbrengt en daarbij ook de ondersteuning voor PHP 7.0 is gaan afbouwen. Een overstap naar PHP 7.2 is daarmee onvermijdelijk. Dit kan echter van grote invloed zijn op de werking van u Joomla, Wordpress of Magento website en het is daarom noodzakelijk om deze gevolgen in kaart te brengen. De meeste hostingproviders zullen namelijk het gebruik van deze versies op termijn stoppen of hebben dit al gedaan.

Hulp nodig met uw website of webshop? Chat met onze experts of stuur ons een bericht! Ik stuur een bericht!

De ondersteuning van PHP

PHP is de meest gebruikte scripttaal om websites mee te bouwen, het wordt gebruikt in bekende Content Management Systemen (CMS) zoals Wordpress, Joomla, en Magento. PHP is daarmee een belangrijke bouwsteen van uw website waarvoor periodiek updates worden uitgebracht. Voor elke PHP-versie wordt vanaf de releasedatum voor gedurende twee jaar ondersteuning gegeven. Gedurende deze periode worden fouten en beveiligingsproblemen verholpen en middels een update uitgebracht.

Nadat de actieve ondersteuning voor een release eindigt na twee jaar wordt gedurende één jaar ondersteuning geboden in de vorm van veiligheidsupdates. Deze updates worden echter alleen ontwikkeld op basis van behoefte en meldingen vanuit de community. Zodra de termijn van 3 jaar is verstreken bereikt de PHP versie zijn EOL en wordt deze niet langer ondersteund. Het is in dat geval aan te raden om gebruik te maken van een actief ondersteunde PHP-versie.

Uw website versus PHP 7.2?

Bekijk in eerste instantie wat uw hosting provider te melden heeft over het overstappen van PHP 5.6 naar PHP 7.2. Een goede hostingprovider zal u namelijk tijdig op de hoogte stellen van het naderende einde van een specifieke PHP-versie. U heeft vervolgens zelf de mogelijkheid om de gevolgen voor uw website te bepalen en hierop actie te ondernemen. De meeste hostingproviders stellen u daarnaast in staat zelf de regie te voeren over de gebruikte PHP-versie. Zo kunt u op voorhand zien of uw website met een nieuwe versie correct functioneert. Een aantal providers biedt daarbij de mogelijkheid om (op eigen risico) een verouderde PHP-versie te gebruiken zodat u verder de tijd heeft om de nodige aanpassingen aan de website uit te voeren.

Uw hostingprovider speelt een belangrijk rol in de veiligheid van uw website en dient te zorgen dat u altijd kan beschikken over de laatste stabiele PHP-versies. We zien nog altijd klanten voorbijkomen waarvan de website draait op PHP 5.5 of lager. Dit vormt een aanzienlijk beveiligingsrisico voor uw website en bezoekers en verdient daarom een evaluatie bij de keuze voor een hostingprovider.

Wat maakt PHP 7.2 zo anders?

Op dit moment zijn PHP 7.2 en 7.3 de versies die actief ondersteund worden en daarmee een logische keuze zijn om uw website compatibel mee te laten zijn. Ten opzichte van PHP 5.6 zijn er in PHP 7.2 veel interessante verbeteringen geïntroduceerd. Elke PHP-versie biedt verschillende verbeteringen waarbij het verschil soms minimaal is (zoals tussen PHP 5.5 en PHP 5.6). In andere gevallen zijn er zoveel veranderingen dat het invloed kan hebben op de werking van uw website. Een voorbeeld hiervan is de overstap van PHP 5.6 naar PHP 7.2.

PHP 7.2 biedt vele voordelen waarvan het aanzienlijke snelheidsvershil het meest merkbaar zal zijn. Uw website zal namelijk veel sneller werken. U en uw bezoekers worden hier natuurlijk blij van, maar Google ook! Google beloont namelijk snelle websites met een hogere positie in de zoekresultaten.


thumb website pagespeed optimaliseren
Een snelle website: hoe doe je dat?

Een ander voordeel is dat het geheugengebruik aanzienlijk wordt verminderd. Basiscode wordt geherstructureerd, waardoor u minder geheugen gebruikt bij het uitvoeren van scripts. Uw website kan zo ook meer bezoekers aan met dezelfde snelheid.

Hulp nodig?

Onze experts helpen u graag! Zo kunnen we uw Joomla, Wordpress of Magento website compatibel maken met nieuwe PHP-versies of u ondersteunen bij het overstappen naar een andere hostingprovider. U neemt gemakkelijk contact met ons op door gebruik te maken van onze live chat of te bellen met 071 - 203 240 8 (werkdagen van 9:00 tot 17:00).

Kies voor professioneel en periodiek onderhoud

Joomla Onderhoud Wordpress Onderhoud